> For clean Markdown of any page, append .md to the page URL.
> For a complete documentation index, see https://docs.nvidia.com/ai-workbench/llms.txt.
> For AI client integration (Claude Code, Cursor, etc.), connect to the MCP server at https://docs.nvidia.com/ai-workbench/_mcp/server.

# VS Code

## Overview

**The AI Workbench integration streamlines attaching VS Code to a project container.**

Adding VS Code to a project in the Desktop App creates an option in the **Application Launcher**.
Launching it starts the container and attaches a VS Code window.

**You add VS Code on a project-by-project basis**

Anyone that clones the project can launch VS Code from the **Application Launcher**.
If VS Code isn't installed, this will initiate the VS Code install.

**There are minor configurations for VS Code for WSL2 or Podman.**

On Windows, you must configure VS Code to use the `NVIDIA-Workbench` WSL distribution.
If you are using Podman locally, you must specifically configure VS Code use it.

## Prerequisites: VS Code and Local Extensions

**Step One: Install VS Code on the same system you have the Desktop App.**

Go to the [Visual Studio Code site](https://code.visualstudio.com/download) and download the version for your operating system.

**Step Two: Install the Remote-SSH extension.**

1. Select **VS Code window > View (Top) > Extensions**
2. Type **Extensions (Top LHS) > Search Bar >** `ms-vscode-remote.remote-ssh`
3. Select **Remote-SSH**

**Step Three: Install the Dev Container extension.**

1. Type **Extensions (Top LHS) > Search Bar >** `ms-vscode-remote.remote-containers`
2. Select **Dev Containers**

<Note title="VS Code requires the WSL extension and *dev.containers.executeInWSL* for full local install on Windows.">

**Step One: Install the WSL extension.**

1. Select **VS Code window > View (Top) > Extensions**
2. Type **Extensions (Top LHS) > Search Bar >** `ms-vscode-remote.remote-wsl`
3. Select **Remote-SSH**

**Step Two: Configure the *NVIDIA-Workbench* distribution.**

1. Select **VS Code window > File > Preferences > Settings**
2. Type **Settings Tab > Search Bar >** `dev.containers.executeInWSL`
3. Select **Execute in WSL**
4. Type **Execute in WSL Distro >** `NVIDIA-Workbench`

</Note>

<Note title="Using Podman with VS Code locally requires configuring *dev.containers.dockerPath*.">

**Do the following in a VS Code window.**

1. Select **File > Preferences > Settings**
2. Type **Settings Tab > Search Bar >** `dev.containers.dockerPath`
3. Type **Docker Path >** `podman`

</Note>

## Add VS Code to a Project

**Step One: Open the project you want to add VS Code to.**

1. Select **Locations Manager > Location Card > Project Card**

**Step Two: Add VS Code to the project.**

1. Select **Project Tab > Project Container > Apps (LHS) > Add**
2. Select **VS Code**

**Success: The modal disappears and the Application Launch shows VS Code in the drop down.**

## Open VS Code in a Project

**Once VS Code is added to the project, just open it using the Application Launcher.**

This will work for local projects and remote projects.

1. Select **Project Tab > Application Launcher > VS Code**