Installing VMA

Before you begin, verify you are using a supported operating system and a supported CPU architecture for your operating system. See supported combinations listed in System Requirements and Interoperability.

The current VMA version can work on top of both MLNX_OFED driver stack that supports Ethernet and on a lighter driver stack, MLNX_EN that supports only Ethernet.

The VMA library is delivered as a user-space library, and is called libvma.so.X.Y.Z.

VMA can be installed using one of the following methods:

VMA is a part of the NVIDIA® drivers (MLNX_OFED/MLNX_EN) and it depends on the latest drivers, firmware, libraries, and kernel modules in the package. This installation assures VMA’s correct functionality. The installation package has multiple supported distributions for RHEL, Ubuntu, and others. Pay attention to selecting the suitable distribution for your operating system.

This option suits user who want to install a new VMA version or upgrade to the latest VMA version by overriding the previous one.

  1. Download the latest MLNX_OFED driver from here.

  2. Install the VMA packages.

    Copy
    Copied!
                

    ./mlnxofedinstall --vma

  3. Verify the installation completed successfully.

    Copy
    Copied!
                

    /etc/infiniband/info

  1. Download the latest MLNX_EN driver from here.

  2. Install the VMA packages.

    Copy
    Copied!
                

    ./install --vma

  3. Verify the installation completed successfully.

    Copy
    Copied!
                

    $ cat /etc/infiniband/info #!/bin/bash   echo prefix=/usr echo Kernel=3.10.0-514.el7.x86_64 echo echo "Configure options: --with-core-mod --with-user_mad-mod --with-user_access-mod --with-addr_trans-mod --with-mlx4-mod --with-mlx4_en-mod --with-mlx5-mod --with-ipoib-mod --with-srp-mod --with-iser-mod --with-isert-mod" echo

  1. Start the relevant driver (MLNX_OFED/MLNX_EN):

    Copy
    Copied!
                

    /etc/init.d/openibd restart

    or

    Copy
    Copied!
                

    systemctl restart openibd.service

  2. Verify that the supported version of firmware is installed.

    Copy
    Copied!
                

    ibv_devinfo

Warning

To configure NVIDIA® ConnectX® adapter card ports to work with the desired transport, please refer to the section Port Type Management/VPI Cards Configuration.

© Copyright 2023, NVIDIA. Last updated on Nov 3, 2023.