Use Windsurf with AI Workbench
Overview
Using Windsurf with AI Workbench is virtually identical to using VS Code or Cursor except for direct integration.
Windsurf has the same features for working on remotes and attaching to containers. However, there is one key difference.
You can’t (yet) configure Windsurf as a Native App and then launch it from the Application Launcher Instead, you must attach it from within Windsurf. It takes three steps.
Windsurf has Remote-SSH and Dev Containers built-in, simplifying setup.
Unlike VS Code and Cursor, Windsurf ships with these extensions already integrated. You don’t need to install any additional extensions for remote development.
You need to start the project container first, then attach a Windsurf window to it.
The lack of direct integration requires three steps. Start the project container, then attach Windsurf to it by connecting to the remote and then the container.
To persist the Windsurf server and extensions, install them in the container with a build script.
This is identical to how it works with VS Code and Cursor. You just need to add the correct code snippet to the postBuild.bash script.
Prerequisites: Windsurf Installation
Step One: Install Windsurf on the same system you have the Desktop App.
Go to the Windsurf site and download the version for your operating system.
Remote-SSH and Dev Containers extensions are built-in.
Unlike VS Code and Cursor, Windsurf includes these extensions by default. No additional extension installation is required for basic remote development.
Configure the NVIDIA-Workbench distribution.
- Select Windsurf window > File > Preferences > Settings
- Type Settings Tab > Search Bar >
dev.containers.executeInWSL - Select Execute in WSL
- Type Execute in WSL Distro >
NVIDIA-Workbench
Do the following in a Windsurf window.
- Select File > Preferences > Settings
- Type Settings Tab > Search Bar >
dev.containers.dockerPath - Type Docker Path >
podman
Attach to a Local Container
Step One: Start the project container.
- Select Location Manager > Location Card > Location Window > Project Card
- Select Project Tab > Dashboard > Project Container > Start Container
Step Two: Connect a Windsurf window to the container.
- Type Windsurf window > Search Bar (Top) >
> Dev Containers: Attach to a Running Container - Hit Enter
- Select Drop Down > container name
- Hit Enter
Step Three: Open the project folder in the Windsurf window.
- Select Windsurf window > Open Folder (LHS)
- Locate the project folder and select it
Attach to a Remote Container
Step One: Start the project container.
- Select Location Manager > Location Card > Location Window > Project Card
- Select Project Tab > Dashboard > Project Container > Start Container
Step Two: Connect a Windsurf window to the remote container.
- Type Windsurf window > Search Bar (Top) >
> Remote-SSH: Connect to Host - Hit Enter
- Select Drop Down > location-name or IP
- Type Windsurf window > Search Bar (Top) >
> Dev Containers: Attach to a Running Container - Hit Enter
Step Three: Open the project folder in the Windsurf window.
- Select Windsurf window > Open Folder (LHS)
- Locate the project folder and select it